27 April 2017

eric6

System: Slackware Linux (version 14.2)
CPU: Intel(R) Core(TM) Duo CPU T2500 @2.00GHz
Deps: eric6-17.04.1.tar.gz
eric6-i18n-en-17.04.1.tar.gz

Installation of eric6-17.04.1.

https://sourceforge.net/projects/eric-ide/files/eric6/stable/17.04.1/

eric6-17.04.1.tar.gz
eric6-i18n-en-17.04.1.tar.gz

https://slackbuilds.org/repository/14.2/development/

https://slackbuilds.org/repository/14.2/libraries/
https://slackbuilds.org/repository/14.2/python/

bash-4.3# installpkg MarkupSafe-0.23-i486-1_SBo.tgz \
> PyStemmer-1.3.0-i586-1_SBo.tgz Pygments-2.1.3-i586-1_SBo.tgz \
> alabaster-0.7.9-i586-1_SBo.tgz cx_Freeze-4.2.3-i486-1_SBo.tgz \
> docutils-0.12-i486-1_SBo.tgz imagesize-0.7.1-i586-1_SBo.tgz \
> pyenchant-1.6.8-i586-1_SBo.tgz python-lazy-object-proxy-1.2.2-i586-1_SBo.tgz \
> python-requests-2.13.0-i586-1_SBo.tgz python-wrapt-1.10.8-i586-1_SBo.tgz \
> pytz-2016.10-i586-1_SBo.tgz six-1.10.0-i586-1_SBo.tgz


...

bash-4.3# installpkg Jinja2-2.7.3-i486-1_SBo.tgz \
> astroid-1.5.2-i586-1_SBo.tgz babel-2.3.4-i586-1_SBo.tgz \
> logilab-common-0.63.2-i486-1_SBo.tgz snowballstemmer-1.2.1-i586-1_SBo.tgz


...

bash-4.3# installpkg Sphinx-1.5.5-i586-1_SBo.tgz \
> pylint-1.5.2-i486-1_SBo.tgz


...

bash-4.3#

A SlackBuild for eric6 is located in the sidebar.

bash-4.3# installpkg eric6-17.04.1-i586-1_SBo.tgz

...

bash-4.3# exit

NB: You need at least Qt version 5.6.0 to execute the eric6 (QtWebEngine) web browser,
which is not supplied with this version of Slackware Linux; while the eric6 (QtWebKit) web
browser works fine.